PHP is one of the most commonly used general-purpose scripting languages. It is quite popular since it is free software, which you can use to create interactive websites such as community portals, e-shops or online teaching sites rather than static HTML-based websites. A PHP module should be activated on the web server where a PHP website is hosted so that its PHP code can be ‘decoded’. Since there are no license taxes for this sort of module and the language itself offers endless possibilities for the apps that you create, there’re hundreds of millions of PHP-powered websites. Besides, there’re tons of PHP-based scripts, which you can use for your sites without the need to possess any programming knowledge. As there’re a handful of PHP versions, you must verify that the same exact version that you used while creating your site is activated on the server as well.

PHP 4, PHP 5 and PHP 7 Support in Web Hosting

With our web hosting plans, you’ll be able to pick the version of PHP that will be active for your shared hosting account, as several versions are installed on our servers. With just one mouse click, you will be able to switch between PHP 4, 5, 7 and each time a new version is launched in the future, we will add it to the Hepsia Control Panel without removing the previous versions. In this way, you will be able to host all the sites that you’ve set up through the years. In contrast with a lot of other web hosting vendors, we will not compel you to update such websites, because a script may be outdated, but this doesn’t necessarily mean that it is vulnerable as you may have done modifications to its code to prevent safety breaches. For your convenience’s sake, you’ll even be able to choose a different PHP version for each website hosted in your shared account.

PHP 4, PHP 5 and PHP 7 Support in Semi-dedicated Servers

In case you have a site based on an older PHP version and you’ve put time and effort toward developing it, fixing security loopholes and inputting web page content, you will need to find a web hosting service that can support it, as the vast majority of hosting companies nowadays support only the most recently launched PHP version and drop the previous versions. We, on the other hand, have decided to allow you to pick the exact version that your very own sites require. Our semi-dedicated hosting plans support PHP 4, PHP 5 and PHP 7, which implies that you will be able to run both newer and older scripts without forfeiting any custom modifications or wasting time and effort striving to make your websites compatible with the hosting platform. You can change the version through the Hepsia Control Panel and such an update will affect the whole semi-dedicated account, but you will also have the ability to select a different PHP version for each single website hosted in your account using an .htaccess config file.